VARIOSYSTEMS

Aegis Software Required
Data Forms

A Guide for our customers of providing BOM and CAD Data

The Aegis software system converts your CAD design data and BOM data into a wide array
of useful information such as robotic assembly machine programs and quality documentation
more quickly and accurately than ever possible with manual methods. More information
can be found on the Aegis Industrial Software Web Site: http://www.aiscorp.com/ or feel free
to contact Variosystems.

This document defines the data it requires, and also how to obtain these forms of data. It is
divided into four sections:

Section 1:

BOM sources for using CircuitCAM only or using CheckPoint’s extended support.

Section 2:

Data that includes all native CAD importers as well as Gerber and scanned bare board importers.
Section 3:

The procedures for extracting the CAD files from the board design software for most CAD sources.

Section 1: BOM Import Sources and Formats

Aegis developed CheckPoint to address the challenges found in most bills of material.
CheckPoint permits users to rapidly import BOMs in various source formats, to verify the
BOM'’s integrity, and to perform both BOM-to-BOM and BOM-to-CAD comparisons. The
validated CheckPoint BOM is directly transmitted to the CircuitCAM project file.

BOM Data Requirements:

In order to successfully process your assemblies with our new CircuitCAM software, we will
require a bill of material. However, more data is always beneficial in order to cope with
unforeseen file difficulties, so if more information and formats are available, please provide
them.

Supported in...
= s
o <
& 3 Optional Optional Additional
S § Required Preferred | Optional Text| Number Boolean Custom Functions in
Format 5 (%) Delimiters Fields Fields Fields Fields Fields BOM Fields | CheckPoint
Part Description, |Part Marking, |[Cost, Height |Polarity, Unlimited Template
Text Fixed Column |Number, Quantity Package, (mils) Socketed Definition, Join
(ASCII) Yes Yes or Character |Reference |(CheckPoint) [Population (Y/N,Yes/No, Multiple Files to
Designators Type, TIF, Form 1 BOM,
Customer P/N, True/False) Analysis
Mfr, Mfr P/N, Reports, Use
Excel Yes No N/A Vendor, Customer or
Vendor P/N, Internal Number
Bin Location, as Primary,
Stock Code, AML/AVL Mgmt,
ODBC Yes No N/A Software Ver, Revision Control
(Access) Part Rev, URL
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Section 2: CAD Import Sources and Formats

CircuitCAM Data Requirements:

In order to successfully process your assemblies with our new CircuitCAM software, we will
require a bill of materials (refer to Section 1) and one of the following groups of board design
data. However, more data is always beneficial in order to cope with unforeseen file difficulties.

Summary Information of Data Sources

Native CAD Data

Accel EDA , Accel Tango, & Accel PCAD
Cadence Allegro via Aegis Script

DIF (Design Interchange Format), PADS DFT Audit, and C-Link
EE Designer Ill ASCII File

GenCADv. 1.4

INCASES TL CAD File

Intergraph Veribest GenCAD

IPC-D-356

Mentor Graphics Neutral File

OrCAD

PADS PowerPCB, PADS Perform, PADS 2000, PADS Work
Pantheon PDB File

P-CAD PDIF Design File

P-CAD for DOS

Protel 98/99 ASCII PCB File

SCI Cards Neutral File

Supermax CAD

Tango for DOS

Ultiboard

Valor ODB++ CAD Project

Zuken Visula and Cadstar

3rd Party CIM Software Applications
Fabmaster FATF File

Panapro / PanaCIM PCB File

Unicam Project File

PCB Design Format Provides Required?
Data
Gerber Data RS-274X, Locations, reference designators, and [YES
RS-274-D board graphics
Aperture List Text File Shape information required to render |RS-274-D: YES
the Gerberi

e lserherimage RS-274-X: NO

Centroid File Text File Relative locations of components NO: However, the use of

(defined by reference designator) on this file expedites Gerber
the PCB. Allows automatic joining of |processing.
references to the Gerber data.
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Assembly Machine Program Data -
Suitable For Machine Programming

CONTACT Systems 3AV/S/Z Series SMT Machines PLA Program and
Libraries

Europlacer Program Files

Fuji Source Programs and Part Data Files

MYDATA automation PCB Files and TPSYS Databases
Panasonic POS File

PHILIPS FTIP-Il Programs

Sanyo Chipshooter Program

SIEMENS Program Files, and Part Databases

Board Design Data:

All CAD systems output Gerber data. Therefore, you can be assured that at least this data has been available at
some time in the product’s life cycle. The photoplotters used to fabricate bare boards are driven by this
data exclusively, and therefore if a bare board exists, someone had access to the Gerber data at one time.

Please obtain at least one of the sets of data listed below.
(The sets are listed in order of preference, 1 being most preferred):

Set 1: Any of the Listed Native CAD File or 3™ Party CIM Software Application
Import Formats
(See Chart above. Section 3 below provides instructions for providing data.)

Set 2: Gerber RS-274D or RS-274X Data Files
Gerber Files to include:
= Aperture List(s) (D-code, Shape, X-size, Y-size) ****RS274D ONLY****
» Top Mask Layer
» Top Silkscreen Layer
- Bottom Mask Layer (if applicable)
- Bottom Silkscreen Layer (if applicable)
Optional but Highly Desirable: ASCII text component location file (Ref, X, Y, theta)

Set 3: ASCII Centroid File
Not essential but helpful if available. Most CAD systems export this file and it is sometimes identified as an
“‘insertion”, “manufacturing”, or “CAM” file. It can be used as a sole CAD information source, but these files
lack graphical information required for proper visual aid and documentation development. The text (ASCII) file
contains the following:

» Reference designators

= X coordinate

* Y coordinate

= Package rotation (theta)

Set 4: Scanned Board Image — Please provide one of the following:
= Scanned Image — (.jpg or .bmp formats)
- Bare Board
= Assembly Drawing

Optional but Highly Desirable: ASCII text component location file (Ref, X, Y, theta)

Set 5: Any of the Listed Machine File Import Formats (See Chart above)
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Section 3: EXTRACTING NATIVE CAD DATA FROM PCB
BOARD DESIGN SOFTWARE

1 Cadence Allegro

Extraction Procedure:
Cadence Allegro requires the use of a script available from
www.variosystems.ch/images/Downloads/Cadence Allegro_script.zip
The script produces a ccam.cad file that can then be imported into CircuitCAM.
Common File Extension: .cad

File header:

A!REFDES!CLASS!SUBCLASS!COMP DEVICE TYPE!COMP PACKAGE!SYM ROTATE!PIN NUMBER!DRILL
HOLE NAME!NET NAME!PIN X!PIN Y!START LAYER NAME!END LAYER NAME!GRAPHIC DATA NAME!G
RAPHIC DATA 1!GRAPHIC DATA 2!GRAPHIC DATA 3!GRAPHIC DATA 4!GRAPHIC DATA 5!GRAPHIC
DATA 6!GRAPHIC DATA 7!GRAPHIC DATA 8!GRAPHIC DATA 9!GRAPHIC DATA 10!SYM NAME!SYM X
!SYM Y!SYM MIRROR!

J!D:\cam\102.brd!Tue Apr 25 15:21:27 2000!-100.000!-
170.000!500.000!430.000!0.001!'millimeters!B01!47.2 mil!6!OUT OF DATE!

S!!BOARD GEOMETRY!OUTLINE!!!0.000!!!!!11TARC!-8.095!-9.949!-8.095!-9.949!-10.000!'~-
9.949!1.905!0.000! COUNTERCLOCKWISE INOTCONNECT! TARGET!-10.000!-10.000!NO!

A Cadence Allegro file can be very easily distinguished by the ! marks in the
output file. 29 data fields are required in the output file.

2 EE Designer Il ASCII File

Common File Extension: .ala

3 GenCAD v 1.4 from Veribest

Extraction Procedure:
Veribest provides a stand-alone application called Report Writer. Use this application to export the
“Mitron” export option, which causes Veribest to produce a GenCAD compliant output ASCII file.

Common File Extension: .cad
File Header:

SHEADER

GENCAD 1.4

USER RSI-TRANSLATOR GENCAD OUTPUT V:10
DRAWING scm

REVISION Wed Jan 07 15:13:12 1998
UNITS USER 1000

ORIGIN 0 O

INTERTRACK 0

SENDHEADER

4 Incases TL CAD File

Common File Extension: Al
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5 IPC-D-356

Common File Extensions: .net or .356
File Header:

P JOB 010670x2.brd

P UNITS CUST

P DIM N

C

C Feb 11 16:26:42 2000

Company.

C IPC-D-356 Netlist From Allegro
C

327N/C - AQ02X-000460Y+036040X1200Y1200R000 sS1

6 Mentor Graphics Expedition

Extraction Procedure:
Select Export under the File menu.
Select the General Interface menu
item. Select the Mitron GenCAD
option.

Common File Extension: .cad
File Header:

See GenCAD section

7 Mentor Graphics Neutral File

Extraction Procedure:
Select the “Write Neutral Files” command from the Output menu of the FabLink
utility. Select to output all options.

Common File Extension: .neu
File Header:
# file : /users/ngd/pci audio/t20318ptl/pcb/mfg/neutral file.mech

# date : Wednesday June 10, 1998; 13:58:18

8 OrCAD

Extraction Procedure:
Open the OrCAD Layout Application. DO NOT OPEN the Project or the
Board. Select Export from the File menu.
Select the GenCAD option.
Browse to the location of the file and
Accept. Common File Extension:
.ca

d File Header: See GenCAD section
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9 135

< PowerPCB

< PADS Perfrom
< PADS 2000

< PADS Work

Extraction Procedure:
Through the In/Out menu, select ASCII Out (F4) command.
Select the “All” option and the PADS-2000 or PADS-3000 format.
Input the name to be used for the output file.

Common File Extension: .asc
File Header:

! PADS-POWERPCB-V4.0-BASIC! DESIGN DATABASE ASCII FILE 1.0
*PCB* GENERAL PARAMETERS OF THE PCB DESIGN

10 PANTHEON PDB File

Common File Extension: none

11 P-CAD
e Accel EDA
» Accel Tango
e Accel PCAD
e P-CAD for DOS
- P-CAD PDIF Design File

Extraction Procedure:
From the File Menu select SAVE
AS Select the ASCIlI .PCB option

Common File Extension: *.pcb
Extraction Procedure:

From the File Menu select Export

Select the PDIF
Common File Extension: *.pdf

OLD EXTRACTION

Select the PCAD menu from main.

Select PCB Tools.

Select the PDIF File Writer option.

Output a complete PDIF data file for the design. (Note that output options are not relevant to CircuitCAM
required data. The CAD user may choose any options.)

. Select the name of the PCB file desired for export.

Input the name of the PDIF file to be created for input to CircuitCAM.

7. Click on Run.

AW N =

AN

Common File Extension: *.pdf
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File Header for PDF:

ShAAKAAIKAKA KA I ALK AAIAA KA A I I AT I AA I I I AR IR A TR T I A A kA Ak kA ok kxkhhkkkkkhkk

% Program : ACCEL P-CAD PCB Version 14.01.03
% Date : Jan 28 1999
% Time : 08:00:05 PM
% File In : c:\accel\demo\modfax0.pcb
% File Out : c:\accel\demo\modfax0.pdf
Format : P-CAD DATABASE INTERCHANGE FORMAT

o° o o°

kA Ak Ak hk kA hhkhhkhh Ak Ak hkhk kA hhkhkhhk kA khkhk kA kA hkhkhkhkhkhk kA hhhkhhkrhkhkhkhkhkhhkhrhkrhkhkkkhkhkxx

File Header for PCB:
ACCEL ASCII "C:\WINDOWS\Desktop\Htrdemo.pcb"

(asciiHeader

asciiVersion 3 0)

timeStamp 2002 1 17 9 18 44)

program "P-CAD 2001 PCB" "16.02.04")

copyright "Copyright © 1991-2001 Altium Limited")
fileAuthor "")

headerString "")

fileUnits Mil)

(
(
(
(
(
(
(
(guidString "{AA3EBDF5-111B-48FC-9292-C084E2766C15}")

12 PROTEL 98/99 ASCII PCB File ver 3

Extraction Procedure:

Within Protel, select the File menu->Save As.
When in the File Format dialog, select ASCII
.PCB

Common File Extension: *.pcb
File Header:

| RECORD=Board|FILENAME=D: \Shoebox\PCB design\SwitchTest\Backup of Copy of
SW_2.PCB|KIND=Protel Advanced PCB|VERSION=3.00|DATE=24-May-

2001 | TIME=11:52:14|ORIGINX=2050mil |ORIGINY=2250mil |[BIGVISIBLEGRIDSIZE=10000000.000
|[VISIBLEGRIDSIZE=100000.000 | ELECTRICALGRIDRANGE=0.5mil |ELECTRICALGRIDENABLED=TRUE |
SNAPGRIDSIZE=5000.000000 | SNAPGRIDSIZEX=5000.000000| SNAPGRIDSIZEY=5000.000000 | TRACK
GRIDSIZE=50000.000000|VIAGRIDSIZE=200000.000000|COMPONENTGRIDSIZE=5000.000000 | COMP
ONENTGRIDSIZEX=5000.000000| COMPONENTGRIDSIZEY=5000.000000| CURRENTWORKINGLAYER=BOTT
OM|DOTGRID=TRUE | DISPLAYUNIT=1 | PLANE1NETNAME= (No Net) | PLANE2NETNAME= (No

Net) | PLANE3NETNAME= (No Net) | PLANE4ANETNAME= (No Net) |PLANESNETNAME= (No

Net) | PLANE6G6NETNAME= (No Net) | PLANE7NETNAME= (No Net) |PLANE8SNETNAME= (No

Net) | PLANEONETNAME= (No Net) |PLANE1ONETNAME= (No Net) |PLANE11NETNAME= (No

Net) | PLANE12NETNAME= (No Net) |PLANE13NETNAME=(No Net) |PLANE14NETNAME= (No

Net) | PLANE15NETNAME= (No Net) | PLANE16NETNAME= (No Net)

13  SCI Cards Neutral File

Extraction Procedure:
From CircuitCAM you must extract a SCI-Cards Neutral file.

Common File Extension: *.Cii
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14  Supermax CAD

Common File Extension: .ipl

15 Tango for DOS

See PCAD .pcb export.

16 Ultiboard

Extraction Procedure:

Use the the DDF2GenCAD convertor v1.30 supplied by Ultiboard.
Import as a Gencad File

File Header: see GencaD

17 Valor ODB++ Cad Project

Extraction Procedure:
A .tar or a .tgz file is normally supplied containing the full directory structure of the
Board. Unzip keeping the directory structure within the .tar file.
To import browse to the MATRIX folder and select the MATRIX file.

Common File Extensions supplied by customer: *.tar or .tgz

18 ZUKEN VISULA and CADSTAR

Extraction Procedure:

In the Job menu, select Interface
option. Select CADIF output from the
list.

Common File Extension: *.paf

CADstar is capable of outputting the CADIF file format.

Please use the output option for CADIF and import via the CircuitCAM Visula/CADIF interpreter.

File Header:

cadif
(format CADIF 4 0)
(design
(dataSet ARCHIVE XFER FILE ROUTE RULES PLACE RULES)
(paper (name "B")
(box (pt -21590000 -13970000) (pt 21590000 13970000))
(designOrigin (pt 0 0))
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